2
$\begingroup$

A very simple question: should we call the tag (as it has been done once) or (as it hasn't been done yet, but I'm sure someone will intuitively type this instead). The other one can then be made a synonym, because people will invariable use both over time.

I will add community wiki answers for both options where people can vote on and edit in any argument they might have for either side.

| |
$\endgroup$
  • $\begingroup$ For future reference, please leave question to open discussion rather than posing all sides of the conversation yourself. If you have an opinion, you can certainly post it as an answer, but it is generally better to let everyone have a voice rather than pre-posting all sides of the conversation yourself. It's not difficult to infer what the community wants from the conversation while allowing for the possibility that there's an issue we have not considered. Polling is generally not a good substitute for discussion. Thanks. $\endgroup$ – Robert Cartaino Aug 17 '15 at 13:48
  • $\begingroup$ @RobertCartaino Thanks, I'll keep that in mind. My intention was not to bias the discussion towards my own opinion by only posting that one (which would mean votes for the other side would have to wait until someone can be bothered to write an answer for it). I can see why that can be in general more harmful than helpful though. $\endgroup$ – Martin Ender Aug 18 '15 at 9:23
6
$\begingroup$

The tag should be called [fragment-shader]

  • It is a more accurate term, as a fragment shader might run multiple times for each pixel (but once for each fragment).
  • OpenGL calls it by this name (e.g. there is GL_FRAGMENT_SHADER)
  • Unity calls it by this name
$\endgroup$
-3
$\begingroup$

The tag should be called [pixel-shader]

  • From a quick Google search, "pixel shader" is the more popular name (1.1M results) than "fragment shader" (300K results).
  • DirectX calls them pixel shaders.
  • Unreal and Cryengine call them pixel shaders.
  • The term "fragment" is needlessly confusing jargon (notwithstanding OpenGL's use of it). "Pixel" is the more familiar and intuitive term.
$\endgroup$
  • $\begingroup$ I call the synonym. Both terms overlaps, fragment is more specific and correct (a fragment is not always a pixel), while pixel is more recallable. $\endgroup$ – psicomante Aug 18 '15 at 3:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .